Jak zainstalować Ruby on Rails na Mac OSX Mavericks

Przez:, Z dnia:

Instalacja narzędzi wiersza polecenia

Wszystkie poniższe komendy są pisanie w Terminalu. Aby go otworzyć wyszukaj frazy "terminal" na Twoim komputerze mac. Pierwszy rezultat wyszukiwania powinien być tym właściwym. Jak go otworzysz, powinieneś zostać przywitany czarnym ekranem terminalu. Będziemy go bardzo dużo używać.

 

*Nota: Jesteś w Chinach? Upewnij się, że masz włączony VPN by oglądać filmy.

Krok 1: Instalacja narzędzi wiersza

Aby zainstalować narzędzia wiersza polecenia wpisz:

$ xcode-select --install

Tą komendą instalujemy niezbędne narzędzia do konfiguracji innych elementów, które pozwolą nam używać Ruby on Rails na komputerze. Ten krok jest bardzo ważny.

Krok 2: Instalacja Homebrew

Homebrew to specjalny program, którego będziemy używać do instalcji pakietów na naszej maszynie.

Napisz w terminalu:

bash

$ ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)"
$ echo 'export PATH=/usr/local/bin:$PATH' >> ~/.bash_profile
$ source ~/.bash_profile

Następnie sprawdź czy wszystko jest skonfigurowane poprawnie:

$ brew doctor

Brew jest stale aktualizowany więc będziemy musieli odpalić te aktualizacje:

$ brew update

Powinieneś odpalić tę komendę przed każdym użyciem brew.

Krok 3: Instalacja RVM, Ruby i Rails

Aby zainstalować Ruby i Rails będziemy używać RVM - Menedżer Wersji Ruby (Ruby Version Manager). Wszystko w jednej próbie, więc może zająć chwilkę. Zwyczajnie wpisz:


$ \curl -sSL https://get.rvm.io | bash -s stable --rails

Wyliczając wszystkie wersje Ruby, które mamy na naszej maszynie, zobaczmy czy wszysko zostało poprawnie zainstalowane:


$ rvm list

Jeżeli używasz ostatniej wersji (w czasie pisania tego była to 2.1.0) jesteś gotowy. Jeżeli nie, możesz wpisać:


$ rvm use 2.1.1 --default

Lub którykolwiek najnowszy.

Teraz jesteś gotowy by tworzyć aplikacje w Ruby on Rails!

Musisz się zalogować by móc oznaczyć tutorial jako ukończony żeby śledzić swój postęp



Komentarze

  • Z dnia: Lukasz Muzyka napisał:

  • Z dnia: Frank napisał:

    Thanks for posting this!!
  • Z dnia: Mark napisał:

    Up and running :) Next step: Learn and start building! Tnx for getting it all at one place :)
  • Z dnia: Philip Lohrmann napisał:

    So simple and I have a problem, probably because my internet connection dropped out, got the following - what to do next? fatal: unable to access 'https://github.com/Homebrew/homebrew/': transfer closed with outstanding read data remaining I tried installing again: -e:69: warning: Insecure world writable dir /usr in PATH, mode 040777 It appears Homebrew is already installed. If your intent is to reinstall you should do the following before running this installer again: rm -rf /usr/local/Cellar /usr/local/.git && brew cleanup rm -rf /usr/local/Cellar /usr/local/.git && brew cleanup -bash: brew: command not found
  • Z dnia: Lukasz Muzyka napisał:

    Hi Philip, Learning to code in China is an extra difficult task. If you're using VPN - try to turn it off. If you haven't been using VPN - try turing it on. If you use Astrill, and most expats in Shangahi do, than try using "stealth mode" if you still can't install things. Try to install brew one more time following instructions from the begining, and let me know if the error persists.
  • Z dnia: Philip Lohrmann napisał:

    I found an uninstall script from someone at the homebrew site and ran it, then retried from beginning - I think it worked but when I ran brew doctor I got the following warning > Warning: You have an outdated version of /usr/bin/install_name_tool installed. This will cause binary package installations to fail. This can happen if you install osx-gcc-installer or RailsInstaller. To restore it, you must reinstall OS X or restore the binary from the OS packages. Probably an unrelated issue, but is this something I should try to address before continuing?
  • Z dnia: Philip Lohrmann napisał:

    I found an uninstall script from someone at the homebrew site and ran it, then retried from beginning - I think it worked but when I ran brew doctor I got the following warning > Warning: You have an outdated version of /usr/bin/install_name_tool installed. This will cause binary package installations to fail. This can happen if you install osx-gcc-installer or RailsInstaller. To restore it, you must reinstall OS X or restore the binary from the OS packages. Probably an unrelated issue, but is this something I should try to address before continuing?
  • Z dnia: Almas Kairatuly napisał:

    Whoops, the Homebrew installer has moved! Please instead run:

    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

    Also, please ask wherever you got this link from to update it to the above. Thanks!

  • Z dnia: Daniel napisał:

    I got that same problem Whoops, the Homebrew installer has moved! Please instead run:

    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

    Also, please ask wherever you got this link from to update it to the above. Thanks!

    please anyone help

Dodaj komentarz

Możesz się zalogować by skomentować