Cómo instalar Ruby on Rails en Mac OSX Mavericks

Por:, en:

Instalación de herramientas en la línea de comandos

Todos los comandos debajo deben de escribirse en un Terminal de Texto (consola de texto). Para iniciar una sesión en el Terminal, ve a búsqueda en tu Mac y simplemente escribe "terminal". El primer resultado debe ser el correcto. Una vez que lo abras, debes de ser recibido por la pantalla negra del terminal. Lo usaremos mucho.

*Nota:¿Estás en China? Asegúrate de que tienes tu VPN si deseas reproducir los vídeos.

Paso 1: Instala la línea de herramientas

Instala la línea de comandos y herramientas, en el terminal, escribe:

$ xcode-select --install

Este comando instalará las herramientas necesarias para configurar otros elementos que permitan ejecutar Ruby on Rails en nuestro ordenador. Este paso es muy importante.

Paso 2: Instala Homebrew

Homebrew es un programa especial que utilizaremos para instalar paquetes en nuestra máquina.

En el terminal, escribe:

bash


$ ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)"
$ echo 'export PATH=/usr/local/bin:$PATH' >> ~/.bash_profile
$ source ~/.bash_profile

A continuación, comprobaremos si todo está configurado correctamente:


$ brew doctor

Brew se actualiza constantemente así que tendremos que ejecutar la actualización


$ brew update

Cada vez que uses el filtro, debes de ejecutar este comando.

Paso 3: Instala RVM y Ruby on Rails

Utilizaremos RVM (Ruby Version Manager) para instalar Ruby on Rails. Todos se instalaran al mismo tiempo, así que puede tardar un poco. Simplemente ejecuta:


$ \curl -sSL https://get.rvm.io | bash -s stable --rails

Vamos a ver si todo está correctamente instalado listando todas las versiones de Ruby que tenemos en nuestra máquina:


$ rvm list

Si estás usando la versión más reciente (la versión más reciente fue 2.1.0, cuando este tutorial fue escrito). Ya estás listo, Si no, puedes ejecutar:


$ rvm use 2.1.1 --default

O Cualquiera que sea la más reciente.

Ahora, estás listo para crear aplicaciones en Ruby on Rails.

Si tu Inicio de sesión serás capaz de marcar esto tutorial Como vas avanzando tu progreso



Comentarios

  • en: Lukasz Muzyka escribió:

  • en: Frank escribió:

    Thanks for posting this!!
  • en: Mark escribió:

    Up and running :) Next step: Learn and start building! Tnx for getting it all at one place :)
  • en: Philip Lohrmann escribió:

    So simple and I have a problem, probably because my internet connection dropped out, got the following - what to do next? fatal: unable to access 'https://github.com/Homebrew/homebrew/': transfer closed with outstanding read data remaining I tried installing again: -e:69: warning: Insecure world writable dir /usr in PATH, mode 040777 It appears Homebrew is already installed. If your intent is to reinstall you should do the following before running this installer again: rm -rf /usr/local/Cellar /usr/local/.git && brew cleanup rm -rf /usr/local/Cellar /usr/local/.git && brew cleanup -bash: brew: command not found
  • en: Lukasz Muzyka escribió:

    Hi Philip, Learning to code in China is an extra difficult task. If you're using VPN - try to turn it off. If you haven't been using VPN - try turing it on. If you use Astrill, and most expats in Shangahi do, than try using "stealth mode" if you still can't install things. Try to install brew one more time following instructions from the begining, and let me know if the error persists.
  • en: Philip Lohrmann escribió:

    I found an uninstall script from someone at the homebrew site and ran it, then retried from beginning - I think it worked but when I ran brew doctor I got the following warning > Warning: You have an outdated version of /usr/bin/install_name_tool installed. This will cause binary package installations to fail. This can happen if you install osx-gcc-installer or RailsInstaller. To restore it, you must reinstall OS X or restore the binary from the OS packages. Probably an unrelated issue, but is this something I should try to address before continuing?
  • en: Philip Lohrmann escribió:

    I found an uninstall script from someone at the homebrew site and ran it, then retried from beginning - I think it worked but when I ran brew doctor I got the following warning > Warning: You have an outdated version of /usr/bin/install_name_tool installed. This will cause binary package installations to fail. This can happen if you install osx-gcc-installer or RailsInstaller. To restore it, you must reinstall OS X or restore the binary from the OS packages. Probably an unrelated issue, but is this something I should try to address before continuing?
  • en: Almas Kairatuly escribió:

    Whoops, the Homebrew installer has moved! Please instead run:

    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

    Also, please ask wherever you got this link from to update it to the above. Thanks!

  • en: Daniel escribió:

    I got that same problem Whoops, the Homebrew installer has moved! Please instead run:

    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

    Also, please ask wherever you got this link from to update it to the above. Thanks!

    please anyone help

Comentar

Tú puedes Inicio de sesión Comentar